summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-04-14 17:54:57 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-08 11:25:26 +0200
commitb8f4ed8f5dee0b268415dd13a3d6d37d36652701 (patch)
tree663dbacbc478691aa989ff379711a107aca734e4 /gnu/packages
parent46fbea36ea908b60e088cfd584d4246a8999c67b (diff)
downloadguix-b8f4ed8f5dee0b268415dd13a3d6d37d36652701.tar.gz
gnu: boost: Update to 1.79.0.
* gnu/packages/boost.scm (boost): Update to 1.79.0.
[source](patches): Add new and remove old upstream patches.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/boost.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 2373dd9feb..ec9228f55d 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -67,7 +67,7 @@
 (define-public boost
   (package
     (name "boost")
-    (version "1.78.0")
+    (version "1.79.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
@@ -75,13 +75,13 @@
                                   (version-with-underscores version) ".tar.bz2"))
               (patches
                (list (boost-patch
-                      ;; 1.78.0 was released with a faulty installation routine:
-                      ;; <https://github.com/bfgroup/b2/pull/113>.
-                      "0001-b2-fix-install.patch" version
-                      "02ljm22a4gcaj10xng8ww8aifrrlzm1pgyp08c06fd75f9pbkrbi")))
+                      ;; 1.79.0 was released with a segmentation fault:
+                      ;; <https://github.com/boostorg/json/issues/692>.
+                      "0001-json-array-erase-relocate.patch" version
+                      "1b0izwj8w92imr8ydzrh522syncprpf82n3kcy6apxn6p54b7p0f")))
               (sha256
                (base32
-                "1k5w6l3xsa9vipwk14sjb1vhsj88xwz7jr964996rcmxsisz30c6"))))
+                "0fggarccddj6q4ifj3kn7g565rbhn4ia1vd45fxb7y57a6fmhpa7"))))
     (build-system gnu-build-system)
     (inputs (list icu4c zlib))
     (native-inputs