summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 00:02:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:44 -0400
commitc339c84f0f22c2e83dcf69bab6697ce034cdefda (patch)
treeccafa53ec936f259d59888bbdb720c562f89cf7b /gnu/packages
parent6c80abe0977907441df2603a00f0be2fcc4e04f0 (diff)
downloadguix-c339c84f0f22c2e83dcf69bab6697ce034cdefda.tar.gz
gnu: Remove python2-backports-shutil-get-terminal-size.
* gnu/packages/python-xyz.scm
(python2-backports-shutil-get-terminal-size): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f605d146c4..b5bebb98c3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10223,36 +10223,6 @@ Python 2 and Python 3.")
          ;; module "backports".
          (delete 'sanity-check))))))
 
-(define-public python2-backports-shutil-get-terminal-size
-  (package
-    (name "python2-backports-shutil-get-terminal-size")
-    (version "1.0.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "backports.shutil_get_terminal_size" version))
-       (sha256
-        (base32
-         "107cmn7g3jnbkp826zlj8rrj19fam301qvaqf0f3905f5217lgki"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda _
-             (invoke "py.test" "-v"))))))
-    (native-inputs
-     (list python2-pytest))
-    (home-page "https://github.com/chrippa/backports.shutil_get_terminal_size")
-    (synopsis "Backport of Python 3.3's @code{shutil.get_terminal_size}")
-    (description
-     "This package provides a backport of the @code{get_terminal_size
-function} from Python 3.3's @code{shutil}.
-Unlike the original version it is written in pure Python rather than C,
-so it might be a tiny bit slower.")
-    (license license:expat)))
-
 (define-public python-waf
   (package
     (name "python-waf")