summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-14 13:35:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-14 13:35:22 +0200
commitc8a6e4abbc4f279f919017d238576cf8724e9456 (patch)
treed4714c79605af7cb1b913fa5af41ccf7199b0b59 /gnu/packages
parentaafd0d2309a7f27dc0f724f682c4faede41cf6c2 (diff)
downloadguix-c8a6e4abbc4f279f919017d238576cf8724e9456.tar.gz
gnu: r-chromvarmotifs: Move to (gnu packages bioinformatics).
* gnu/packages/bioconductor.scm (r-chromvarmotifs): Move this variable from here...
* gnu/packages/bioinformatics.scm (r-chromvarmotifs): ...to here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm28
-rw-r--r--gnu/packages/bioinformatics.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ecb188a84f..f795b6ad9c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1211,34 +1211,6 @@ single-cell data or deconvolution of bulk RNA-seq.")
 chromstaR package.")
     (license license:gpl3)))
 
-(define-public r-chromvarmotifs
-  (let ((commit "38bed559c1f4770b6c91c80bf3f8ea965da26076")
-        (revision "1"))
-    (package
-      (name "r-chromvarmotifs")
-      (version (git-version "0.2.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/GreenleafLab/chromVARmotifs")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "0i9v1m1hrg1lkd2pnkj5nnrpks6vhhhpbdhsfl2lmjak4npxxr5q"))))
-      (properties `((upstream-name . "chromVARmotifs")))
-      (build-system r-build-system)
-      (propagated-inputs
-       `(("r-tfbstools" ,r-tfbstools)))
-      (home-page "https://github.com/GreenleafLab/chromVARmotifs")
-      (synopsis "Stores motif collections for use with motifmatchr or chromVAR")
-      (description
-       "This package stores motif collections as lists of @dfn{position
-frequency matrix} (PWMatrixList) objects provided by the @code{TFBSTools}
-package for use in R with packages like @code{motifmatchr} or
-@code{chromVAR}.")
-      (license license:expat))))
-
 (define-public r-copyhelper
   (package
     (name "r-copyhelper")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e3bbdaa380..b838c2dbfa 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8981,6 +8981,34 @@ analysis, variant tools is project based and provides a whole set of tools to
 manipulate and analyze genetic variants.")
     (license license:gpl3+)))
 
+(define-public r-chromvarmotifs
+  (let ((commit "38bed559c1f4770b6c91c80bf3f8ea965da26076")
+        (revision "1"))
+    (package
+      (name "r-chromvarmotifs")
+      (version (git-version "0.2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/GreenleafLab/chromVARmotifs")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0i9v1m1hrg1lkd2pnkj5nnrpks6vhhhpbdhsfl2lmjak4npxxr5q"))))
+      (properties `((upstream-name . "chromVARmotifs")))
+      (build-system r-build-system)
+      (propagated-inputs
+       `(("r-tfbstools" ,r-tfbstools)))
+      (home-page "https://github.com/GreenleafLab/chromVARmotifs")
+      (synopsis "Stores motif collections for use with motifmatchr or chromVAR")
+      (description
+       "This package stores motif collections as lists of @dfn{position
+frequency matrix} (PWMatrixList) objects provided by the @code{TFBSTools}
+package for use in R with packages like @code{motifmatchr} or
+@code{chromVAR}.")
+      (license license:expat))))
+
 (define-public r-raremetals2
   (package
     (name "r-raremetals2")