summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:04:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:43 +0200
commitd0d2bc3b0a6750923dd2a4897c5bdca036f66bab (patch)
treeff03cbe14c93dbb891c2065af6f3bc830629961b /gnu/packages
parent0de349ad79dfa6ed094af275278b5d9e2d8a2453 (diff)
downloadguix-d0d2bc3b0a6750923dd2a4897c5bdca036f66bab.tar.gz
gnu: Add texlive-schemata.
* gnu/packages/tex.scm (texlive-schemata): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 16dea437b7..6a89bedc77 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3615,6 +3615,28 @@ The rule widths are 0.05mm, which can be challenging for (old) laser
 printers.")
     (license license:gpl3+)))
 
+(define-public texlive-schemata
+  (package
+    (name "texlive-schemata")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/schemata/"
+                   "source/generic/schemata/"
+                   "tex/generic/schemata/")
+             (base32
+              "1196653ankylbcsiv1cnrrazz2qplcs27llpv947h4m94vx4sl19")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/schemata")
+    (synopsis "Print topical diagrams")
+    (description
+     "The package facilitates the creation of topical schemata, i.e.,
+outlines that use braces (or facsimiles thereof) to illustrate the breakdown
+of concepts and categories in Scholastic thought from late medieval and early
+modern periods.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")