summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-01 03:06:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:53 -0400
commitd0d694355c2eacc66e0f89b3a4940d9a8c6694d7 (patch)
tree319f4c807008bcf07390c64263ef895d18c23d01 /gnu/packages
parent0f3cd86c67f767b7931871546bbac441483d0a1b (diff)
downloadguix-d0d694355c2eacc66e0f89b3a4940d9a8c6694d7.tar.gz
gnu: Remove python2-freezegun.
* gnu/packages/check.scm (python2-freezegun): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0618ddbd03..be67b20d76 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2794,37 +2794,6 @@ create data based on random numbers and yet remain repeatable.")
 time by mocking the datetime module.")
     (license license:asl2.0)))
 
-(define-public python2-freezegun
-  (package
-    (name "python2-freezegun")
-    (version "0.3.14")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "freezegun" version))
-       (sha256
-        (base32 "0al75mk829j1izxi760b7yjnknjihyfhp2mvi5qiyrxb9cpxwqk2"))))
-    (build-system python-build-system)
-    (native-inputs
-     (list python2-mock python2-pytest))
-    (propagated-inputs
-     (list python2-six python2-dateutil))
-    (arguments
-     `(#:python ,python-2
-       #:phases
-       (modify-phases %standard-phases
-         ;; The tests are normally executed via `make test`, but the PyPi
-         ;; package does not include the Makefile.
-         (replace 'check
-           (lambda _
-             (invoke "pytest" "-vv"))))))
-    (home-page "https://github.com/spulec/freezegun")
-    (synopsis "Test utility for mocking the datetime module")
-    (description
-     "FreezeGun is a library that allows your python tests to travel through
-time by mocking the datetime module.")
-    (license license:asl2.0)))
-
 (define-public python-flexmock
   (package
     (name "python-flexmock")