summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-22 12:12:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-22 14:17:13 +0200
commite1a94fe09cb81d0757b8c35356d3e5ad15f6f9f8 (patch)
treefd89c27c478d1b19bb4afffadfa76cb288f51041 /gnu/packages
parenta4b4c1aa0bb9a3f44545ef5db6184fd3bb5a1dfc (diff)
downloadguix-e1a94fe09cb81d0757b8c35356d3e5ad15f6f9f8.tar.gz
gnu: pass-rotate: Don't use unstable tarball.
* gnu/packages/password-utils.scm (pass-rotate)[source]: Download using
git-fetch. Reflow section.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/password-utils.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index e896e3db2d..3e6212f38b 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
@@ -962,14 +962,15 @@ to use a different password manager.")
     (name "pass-rotate")
     (version "0.1")
     (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/SirCmpwn/pass-rotate/archive/"
-                           version ".tar.gz"))
-       (sha256
-        (base32
-         "1svm5nj8bczv2dg8lh2zqqhbsrljqsw9680r03qwgl9vlci90210"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/SirCmpwn/pass-rotate")
+               (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1m067vvdlc85csbpkp8aw4s3ags7q8s3jszrr32kmj9qhk5c254f"))))
     (build-system python-build-system)
     (inputs
      `(("python-beautifulsoup4" ,python-beautifulsoup4)