summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:50:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:29 +0200
commiteb1d39e74fa80d4f2f7a2478d978fdf468edb277 (patch)
tree5ebf8aa34c74bbc366b482e6889ec918033bd824 /gnu/packages
parent776f81828ca9128357e22bc444d1d95088d9b200 (diff)
downloadguix-eb1d39e74fa80d4f2f7a2478d978fdf468edb277.tar.gz
gnu: Add texlive-fontch.
* gnu/packages/tex.scm (texlive-fontch): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fcc4d3a2f8..71dfa0aed3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2627,6 +2627,29 @@ only one statement.  The fonts may be used readily at various predefined
 sizes.")
     (license license:cc-by-sa3.0)))
 
+(define-public texlive-fontch
+  (package
+    (name "texlive-fontch")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/fontch/" "tex/plain/fontch/")
+             (base32
+              "19v8l76181yhan6ybc47i5sq4mirc8lc7x1zxqxmk15wyvax9lm9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/fontch")
+    (synopsis "Changing fonts, sizes and encodings in Plain TeX")
+    (description
+     "The fontch macros allow the user to change font size and family anywhere
+in a plain TeX document.  Sizes of 8, 10, 12, 14, 20 and 24 points are
+available.  A sans serif family is defined in addition to the families already
+defined in plain TeX. Optional support for Latin Modern T1 and TS1 fonts is
+given.  There are macros for non-latin1 letters and for most TS1 symbols.
+Math mode always uses CM fonts.  A command for producing doubled-spaced
+documents is also provided.")
+    (license license:lppl)))
+
 (define-public texlive-fontools
   (package
     (name "texlive-fontools")