summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:05:02 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:50 +0200
commit20f48e4b5da6b0ea818a10651900ed62315348e2 (patch)
tree493a0d048421c42577621460164de1361ec2ddf9 /gnu/packages
parentad8d4637400f3120320f8012d12065ab48291f3a (diff)
downloadguix-20f48e4b5da6b0ea818a10651900ed62315348e2.tar.gz
gnu: Add go-github-com-sabhiram-go-gitignore.
* gnu/packages/golang.scm (go-github-com-sabhiram-go-gitignore): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d1b5c86624..f614c41d67 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3181,3 +3181,30 @@ as conversion to and from @command{net.Addr}.")
 - because testing panics is ugly.
 @end itemize\n")
       (license license:expat))))
+
+(define-public go-github-com-sabhiram-go-gitignore
+  (let ((commit "d3107576ba9425fc1c85f4b3569c4631b805a02e")
+        (revision "0"))
+    (package
+      (name "go-github-com-sabhiram-go-gitignore")
+      (version (git-version "1.0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/sabhiram/go-gitignore.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1rdwyxgcsiwgmlqnc3k6h300mzlvjc3j21np4yh1h476wc8dvl0l"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path
+         "github.com/sabhiram/go-gitignore"))
+      (native-inputs
+       `(("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)))
+      (home-page "https://github.com/sabhiram/go-gitignore")
+      (synopsis "Gitignore parser for Go")
+      (description "A @command{.gitignore} parser for Go.")
+      (license license:expat))))