summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-07 17:56:20 -0700
committerTimothy Sample <samplet@ngyro.com>2019-09-02 23:09:38 -0400
commit55f4c6533656873a21dcea5a7e4e4b1faef22d42 (patch)
tree309277be40f77848ade315998dc27f6ff6cb4c84 /gnu/packages
parent1307e4c73d25cd89996b0841c2f84a84acbdb573 (diff)
downloadguix-55f4c6533656873a21dcea5a7e4e4b1faef22d42.tar.gz
gnu: Add ghc-storable-tuple.
* gnu/packages/haskell-xyz.scm (ghc-storable-tuple): New variable.

Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fd4d464cfc..c98e65dcef 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9452,6 +9452,34 @@ generates the smallest layout that is possible with respect to the
 alignment of the record elements.")
     (license license:bsd-3)))
 
+(define-public ghc-storable-tuple
+  (package
+    (name "ghc-storable-tuple")
+    (version "0.0.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "https://hackage.haskell.org/package/storable-tuple/"
+         "storable-tuple-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0dfzhxgkn1l6ls7zh6iifhyvhm8l47n40z0ar23c6ibsa94w1ynw"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-storable-record" ,ghc-storable-record)
+       ("ghc-utility-ht" ,ghc-utility-ht)
+       ("ghc-base-orphans" ,ghc-base-orphans)))
+    (home-page "https://hackage.haskell.org/package/storable-tuple")
+    (synopsis "Storable instance for pairs and triples")
+    (description "This package provides a Storable instance for pairs
+and triples which should be binary compatible with C99 and C++.  The
+only purpose of this package is to provide a standard location for this
+instance so that other packages needing this instance can play nicely
+together.")
+    (license license:bsd-3)))
+
 (define-public ghc-storablevector
   (package
     (name "ghc-storablevector")