summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-13 15:00:20 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-15 12:12:11 +0100
commit852ba10a548bc87d8e23700fe12538340665f225 (patch)
tree2dd61bc17c66486a0bb20da0ea4dbb5d5c1faebb /gnu/packages
parent5830168207705a98b132bc0c15b1ece6f7132b0a (diff)
downloadguix-852ba10a548bc87d8e23700fe12538340665f225.tar.gz
gnu: vis: Update to 0.4.
* gnu/packages/text-editors.scm (vis): Update to 0.4.
[arguments]: Document the #:tests situation and the (broken) #:test-target.
[inputs]: Add tre.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/text-editors.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 7843c120aa..6f4d44f0d9 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2017 Feng Shu <tumashu@163.com>
 ;;; Copyright © 2017 ng0 <ng0@infotropique.org>
 ;;; Copyright © 2014 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.org>
+;;; Copyright © 2014 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -40,6 +41,7 @@
   #:use-module (gnu packages lua)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages regex)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages terminals)
   #:use-module (gnu packages xml))
@@ -47,17 +49,19 @@
 (define-public vis
   (package
     (name "vis")
-    (version "0.3")
+    (version "0.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/martanne/"
                                   name "/archive/v" version ".tar.gz"))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
-               (base32 "0xvhkj4j8pcmpnsx7f93d6n2f068xnl7wacfs97vr0agxwrfvn5y"))))
+               (base32
+                "1iclfsc9vn40fqfiz56vrw6dmr4x8q9gvav0b53kkpc6zcfa86zi"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f ; No tests.
+     `(#:test-target "test"
+       #:tests? #f                  ; no releases; snapshots are missing tests
        #:phases
        (modify-phases %standard-phases
          (add-after 'install 'wrap-binary
@@ -80,7 +84,8 @@
     (inputs `(("lua", lua)
               ("ncurses", ncurses)
               ("libtermkey", libtermkey)
-              ("lua-lpeg", lua-lpeg)))
+              ("lua-lpeg", lua-lpeg)
+              ("tre" ,tre)))
     (synopsis "Vim-like text editor")
     (description
      "Vis aims to be a modern, legacy free, simple yet efficient vim-like text