summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-04-03 13:46:17 -0400
committerCarl Dong <contact@carldong.me>2020-04-03 14:13:36 -0400
commitc1c50cb5b099897a18e4cd8c27970cb45a7c3a94 (patch)
tree71022441dd45ee095a9e6e92c1b9a8a5dbba703e /gnu/packages
parente7a353ed468a805af6ad6b06b0dc0909393ff8fa (diff)
downloadguix-c1c50cb5b099897a18e4cd8c27970cb45a7c3a94.tar.gz
gnu: cross-base: Fix PACKAGE-WITH-EXTRA-PATCHES
This also removes the execute bit from the patches added. Not sure how
or why those were set in the first place.

* gnu/packages/cross-base.scm (package-with-extra-patches): Imitate
PACKAGE-WITH-PATCH instead of using it.
* gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch:
Remove execute bit.
* gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch:
Remove execute bit.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cross-base.scm10
-rw-r--r--[-rwxr-xr-x]gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch0
-rw-r--r--[-rwxr-xr-x]gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch0
3 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index dc63dc9462..add1a6fe91 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -76,11 +76,13 @@
     (source (origin (inherit (package-source original))
               (patches (list patch))))))
 
-(define (package-with-extra-patches original patches)
+(define (package-with-extra-patches original extra-patches)
   "Return package ORIGINAL with all PATCHES appended to its list of patches."
-  (package-with-patch original
-                      `(,@(origin-patches (package-source original))
-                        ,@patches)))
+  (let ((original-origin (package-source original)))
+    (package (inherit original)
+      (source (origin (inherit original-origin)
+                (patches `(,@extra-patches
+                           ,@(origin-patches original-origin))))))))
 
 (define (cross-binutils target)
   "Return a cross-Binutils for TARGET."
diff --git a/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch b/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
index 3e48b87935..3e48b87935 100755..100644
--- a/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
+++ b/gnu/packages/patches/binutils-mingw-w64-reproducible-import-libraries.patch
diff --git a/gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch b/gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch
index b785043b62..b785043b62 100755..100644
--- a/gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch
+++ b/gnu/packages/patches/binutils-mingw-w64-specify-timestamp.patch