summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-22 14:51:42 +0200
committerMarius Bakke <marius@gnu.org>2022-07-23 19:43:11 +0200
commit17f0e8d24f56bb0bdfcbc14b482cfcba30f57ad0 (patch)
treef9a7ce9669e9ce5e9484c1687d48d2d2da8c215a /gnu/packages
parentf46d117838ebed353ca160ec47eeae4448fd21ac (diff)
downloadguix-17f0e8d24f56bb0bdfcbc14b482cfcba30f57ad0.tar.gz
gnu: python-mako: Update to 1.2.1.
* gnu/packages/python-xyz.scm (python-mako): Update to 1.2.1.
[native-inputs]: Change from PYTHON-NOSE to PYTHON-PYTEST.
[arguments]: Adjust check phase accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0ef24da0a2..cc7d6860bf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14920,27 +14920,27 @@ of @acronym{REGEXPs, regular expressions}.")
 (define-public python-mako
   (package
     (name "python-mako")
-    (version "1.1.3")
+    (version "1.2.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Mako" version))
        (sha256
         (base32
-         "09ywrmhr6gdyfx6d5727wwjnz73i6rklqcb4c14m7sqc830wi5c1"))))
+         "01q3gdqpxqcxdhacrzrwk6fjpd1krdr73i7cm4d2yja38zzsam7h"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (replace 'check
                     (lambda* (#:key tests? #:allow-other-keys)
                       (if tests?
-                          (invoke "nosetests" "-v")
+                          (invoke "pytest" "-vv")
                           (format #t "test suite not run~%"))
                       #t)))))
     (propagated-inputs
      (list python-markupsafe))
     (native-inputs
-     (list python-mock python-nose))
+     (list python-mock python-pytest))
     (home-page "https://www.makotemplates.org/")
     (synopsis "Templating language for Python")
     (description "Mako is a templating language for Python that compiles