summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-17 00:16:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:20 +0200
commit1f26a78e161517e8c4a44bffca95321870458c6f (patch)
tree5d5619e4d3d421c59491be56b45c5cea2f7601ad /gnu/packages
parentc630edbefe579c863c6985133ab648a1a96f235f (diff)
downloadguix-1f26a78e161517e8c4a44bffca95321870458c6f.tar.gz
gnu: texlive-cm-super: Refresh package definition.
* gnu/packages/tex.scm (texlive-cm-super): Remove SIMPLE-TEXLIVE-PACKAGE
call.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm50
1 files changed, 24 insertions, 26 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index afc3711ebb..866fa15e5b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1276,36 +1276,34 @@ provided for use with TeX.")
     (license license:gpl2+)))
 
 (define-public texlive-cm-super
-  (let ((template (simple-texlive-package
-                   "texlive-cm-super"
-                   (list "/doc/fonts/cm-super/"
-                         "/dvips/cm-super/"
-                         "/fonts/afm/public/cm-super/"
-                         "/fonts/enc/dvips/cm-super/"
-                         "/fonts/map/dvips/cm-super/"
-                         "/fonts/map/vtex/cm-super/"
-                         "/fonts/type1/public/cm-super/"
-                         "/tex/latex/cm-super/")
-                   (base32
-                    "1k3afl0x0bqbr5mnawbnp7rr2126dwn0vwnxzibm9ggvzqilnkm6")
-                   #:trivial? #t)))
-    (package
-      (inherit template)
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:phases phases)
-          `(modify-phases ,phases
-             (delete 'reset-gzip-timestamps)))))
-      (home-page "https://www.ctan.org/pkg/cm-super")
-      (synopsis "Computer Modern Super family of fonts")
-      (description "The CM-Super family provides Adobe Type 1 fonts that replace
-the T1/TS1-encoded Computer Modern (EC/TC), T1/TS1-encoded Concrete,
+  (package
+    (name "texlive-cm-super")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/cm-super/"
+                   "dvips/cm-super/"
+                   "fonts/afm/public/cm-super/"
+                   "fonts/enc/dvips/cm-super/"
+                   "fonts/map/dvips/cm-super/"
+                   "fonts/map/vtex/cm-super/"
+                   "fonts/type1/public/cm-super/"
+                   "tex/latex/cm-super/")
+             (base32
+              "1k3afl0x0bqbr5mnawbnp7rr2126dwn0vwnxzibm9ggvzqilnkm6")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/cm-super")
+    (synopsis "Computer Modern Super family of fonts")
+    (description
+     "The CM-Super family provides Adobe Type 1 fonts that replace the
+T1/TS1-encoded Computer Modern (EC/TC), T1/TS1-encoded Concrete,
 T1/TS1-encoded CM bright and LH Cyrillic fonts (thus supporting all European
 languages except Greek), and bringing many ameliorations in typesetting
 quality.  The fonts exhibit the same metrics as the METAFONT-encoded
 originals.")
-      ;; With font exception
-      (license license:gpl2+))))
+    ;; With font exception
+    (license license:gpl2+)))
 
 (define-deprecated-package texlive-fonts-cm-super texlive-cm-super)