summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-05 23:22:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-06 10:15:04 +0200
commit471f6504983c7bd266603512910b9445c995e5e5 (patch)
tree29d9026b6fe55aa615ed12a85a5cd52408fe6f55 /gnu/packages
parentb4da7c213336342c2f345a45d7b2e9105a893638 (diff)
downloadguix-471f6504983c7bd266603512910b9445c995e5e5.tar.gz
gnu: Add python-kneed.
* gnu/packages/python-xyz.scm (python-kneed): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aa74063ace..4b23dac960 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19337,6 +19337,26 @@ multitouch applications.")
     (description "This package provides a MediaWiki API client.")
     (license license:expat)))
 
+(define-public python-kneed
+  (package
+    (name "python-kneed")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "kneed" version))
+       (sha256
+        (base32 "0vkwi0pr7nfkp3c46hnmx0275yx68v96v10rmspv0wis33x6f39l"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-matplotlib python-numpy python-scipy))
+    (home-page "https://github.com/arvkevi/kneed")
+    (synopsis "Knee-point detection in Python")
+    (description "This package implements the kneedle algorithm.  Given a set
+of x and y values, kneed will return the knee point of the function.  The knee
+point is the point of maximum curvature.")
+    (license license:bsd-3)))
+
 (define-public python-utils
   (package
     (name "python-utils")