summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:57:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:36 +0200
commit6370d2f9c515a3b225a1ae0e2c36882c4eb98e93 (patch)
treeb601800ba1a1d83a3a1591413149e7a860a9b54f /gnu/packages
parenta6c7cfc6e6ee0ba1ae90463865e5ea1c21ed8fac (diff)
downloadguix-6370d2f9c515a3b225a1ae0e2c36882c4eb98e93.tar.gz
gnu: Add texlive-newsletr.
* gnu/packages/tex.scm (texlive-newsletr): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3b683d653a..dc20f29841 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3191,6 +3191,25 @@ information and PDF viewer's display (not in ConTeXt); and commands to create
 and use raw PDF objects.")
     (license license:lppl)))
 
+(define-public texlive-newsletr
+  (package
+    (name "texlive-newsletr")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/newsletr/" "tex/plain/newsletr/")
+             (base32
+              "0c7ggyx1jnw05vn589awxxbpfqkwf7kq4qn9pm61ycb6p9n3nn0h")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/newsletr")
+    (synopsis "Macros for making newsletters with Plain TeX")
+    (description
+     "This package provides macros for making newsletters with Plain TeX.")
+    ;; License is almost Knuth's, but requires marking modifications
+    ;; explicitly instead of simply renaming the file.
+    (license (license:fsf-free "file://doc/plain/newsletr/read.me"))))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")