summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-22 20:25:44 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-06 15:23:06 +0200
commit69505bec93ef7e7c79b7ed619e15a19845618a23 (patch)
tree9830575b71310c649e2444b0a8ef66c55aa90547 /gnu/packages
parenta2d44231ea75a1fc471bf37813aa076e1d8dfea6 (diff)
downloadguix-69505bec93ef7e7c79b7ed619e15a19845618a23.tar.gz
gnu: fenics-dolfin: Honor #:tests? flag.
* gnu/packages/simulation.scm (fenics-dolfin)[source]: Remove trailing
boolean.
[arguments]: Adjust custom 'check' phase to honor the #:tests? flag. While
here, remove trailing booleans.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/simulation.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 3f2d8e136d..757738e627 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -448,8 +448,7 @@ FFC is part of the FEniCS Project.")
               ;; Specify directory to find the header file.
               (("(^set\\(CATCH_INCLUDE_DIR ).*(/catch\\))" _ front back)
                (string-append front
-                              "$ENV{CATCH_DIR}/include" back "\n")))
-            #t))))
+                              "$ENV{CATCH_DIR}/include" back "\n")))))))
     (build-system cmake-build-system)
     (inputs
      `(("blas" ,openblas)
@@ -494,8 +493,7 @@ FFC is part of the FEniCS Project.")
              (setenv "SLEPC_DIR" (assoc-ref %build-inputs "slepc"))
              (setenv "SCOTCH_DIR" (assoc-ref %build-inputs "scotch"))
              (setenv "SUNDIALS_DIR" (assoc-ref %build-inputs "sundials"))
-             (setenv "UMFPACK_DIR" (assoc-ref %build-inputs "suitesparse"))
-             #t))
+             (setenv "UMFPACK_DIR" (assoc-ref %build-inputs "suitesparse"))))
          (add-before 'check 'pre-check
            (lambda _
              ;; The Dolfin repository uses git-lfs, whereby web links are
@@ -546,15 +544,15 @@ FFC is part of the FEniCS Project.")
                     "demo_mesh-quality_serial "
                     "demo_mesh-quality_mpi "
                     "demo_multimesh-stokes_serial "
-                    ")\n") port)))
-             #t))
+                    ")\n") port)))))
          (replace 'check
-           (lambda _
-             (and (invoke "make" "unittests")
-                  (invoke "make" "demos")
-                  (invoke "ctest" "-R" "unittests")
-                  (invoke "ctest" "-R" "demo" "-R" "serial")
-                  (invoke "ctest" "-R" "demo" "-R" "mpi")))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "make" "unittests")
+               (invoke "make" "demos")
+               (invoke "ctest" "-R" "unittests")
+               (invoke "ctest" "-R" "demo" "-R" "serial")
+               (invoke "ctest" "-R" "demo" "-R" "mpi")))))))
     (home-page "https://bitbucket.org/fenics-project/dolfin/")
     (synopsis "Problem solving environment for differential equations")
     (description