summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-27 23:01:35 +0200
committerRoel Janssen <roel@gnu.org>2021-05-27 23:01:35 +0200
commit87c9f63fce05063c190e277a8d79803fa3693e11 (patch)
treec9c26f94eca122cc7c8550240f22e1ed3c30943f /gnu/packages
parenta30e616cccc850f0c9ad809be7db82729f46d0d8 (diff)
downloadguix-87c9f63fce05063c190e277a8d79803fa3693e11.tar.gz
gnu: Add python-pyega3.
* gnu/packages/bioinformatics.scm (python-pyega3): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6f3bc96c9e..f38c0c07ef 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1994,6 +1994,45 @@ multiple sequence alignments.")
 (define-public python2-bx-python
   (package-with-python2 python-bx-python))
 
+(define-public python-pyega3
+  (package
+    (name "python-pyega3")
+    (version "3.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pyega3" version))
+              (sha256
+               (base32
+                "1k736in8g27rarx65ym9xk50x53zjg75h37bb8ljynxv04rypx2q"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ; The tests require network access.
+    (native-inputs
+     `(("python-psutil" ,python-psutil)
+       ("python-htsget" ,python-htsget)))
+    (propagated-inputs
+     `(("python-requests" ,python-requests)
+       ("python-tqdm" ,python-tqdm)
+       ("python-urllib3" ,python-urllib3)
+       ("python-responses" ,python-responses)))
+    (home-page "https://github.com/EGA-archive/ega-download-client")
+    (synopsis "Python client for EGA")
+    (description "This package is a python-based tool for viewing and
+downloading files from authorized EGA datasets.  It uses the EGA data API and
+has several key features:
+@itemize
+@item Files are transferred over secure https connections and received
+  unencrypted, so no need for decryption after download.
+@item Downloads resume from where they left off in the event that the
+  connection is interrupted.
+@item Supports file segmenting and parallelized download of segments,
+  improving overall performance.
+@item After download completes, file integrity is verified using checksums.
+@item Implements the GA4GH-compliant htsget protocol for download of genomic
+  ranges for data files with accompanying index files.
+@end itemize\n")
+    (license license:asl2.0)))
+
 (define-public python-pysam
   (package
     (name "python-pysam")