summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:57:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:36 +0200
commita6c7cfc6e6ee0ba1ae90463865e5ea1c21ed8fac (patch)
treec212009d11753ee1457fa56dac197ca03ccd414f /gnu/packages
parent71a23462d9526bf383494016bc868b82ea88129f (diff)
downloadguix-a6c7cfc6e6ee0ba1ae90463865e5ea1c21ed8fac.tar.gz
gnu: Add texlive-navigator.
* gnu/packages/tex.scm (texlive-navigator): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 94696d721d..3b683d653a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3168,6 +3168,29 @@ number, giving parameters a semantic rather than syntactic meaning, making it
 easy to understand long definitions.")
     (license license:lppl1.3c)))
 
+(define-public texlive-navigator
+  (package
+    (name "texlive-navigator")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/navigator/"
+                   "tex/generic/navigator/")
+             (base32
+              "17rs718rvp9f6dakdl99abgq5rcflsw6kyxjknhjya019l2y23m3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/navigator")
+    (synopsis "PDF features across formats and engines")
+    (description
+     "Navigator implements PDF features for all formats (with some limitations
+in ConTeXt) with pdfTeX, LuaTeX and XeTeX.  Its features include: customizable
+outlines (i.e.  bookmarks); anchors; links and actions (e.g., JavaScript or
+user-defined PDF actions); file embedding (not in ConTeXt); document
+information and PDF viewer's display (not in ConTeXt); and commands to create
+and use raw PDF objects.")
+    (license license:lppl)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")