summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-11 13:01:11 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-11 13:01:11 +0200
commitf69cf40741f6ba4e79a5e8f6dae407d96f4433ec (patch)
tree2eb7f070bdf9e64d3d2098e5626cfc46ac9a2648 /gnu/packages
parentfbe17e242b539004e3aa1458c2e9ccbc635ddfb8 (diff)
downloadguix-f69cf40741f6ba4e79a5e8f6dae407d96f4433ec.tar.gz
gnu: 'define-deprecated-guile3.0-package' actually exports <package> objects.
Until now, that macro would expand to something like:

  (export guile3.0-git)

where 'guile3.0-git' is actually a macro (produced by
'define-deprecated'), which would thus be skipped by 'fold-packages'.
Consequently, "guix install guile3.0-git" would say that no such package
exists.

* gnu/packages/guile.scm (define-deprecated-guile3.0-package): Add
'old-name' and export it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index f17a9aaf59..ef1e19c6b8 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -430,11 +430,19 @@ GNU@tie{}Guile.  Use the @code{(ice-9 readline)} module and call its
                          (datum->syntax
                           #'name
                           (string->symbol
-                           (->guile (symbol->string (syntax->datum #'name)))))))
+                           (->guile (symbol->string (syntax->datum
+                                                     #'name))))))
+                       (old-name
+                        ;; XXX: This is the name generated by
+                        ;; 'define-deprecated'.
+                        (datum->syntax
+                         #'name
+                         (symbol-append '% (syntax->datum #'name)
+                                        '/deprecated))))
            #'(begin
                (define-deprecated name package
                  (deprecated-package package-name package))
-               (export name))))))))
+               (export old-name))))))))
 
 (define-deprecated-guile3.0-package guile3.0-readline)