summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-06-08 19:04:45 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-08 19:06:06 +0200
commit0c0d84603d63ae9eb04edf39582a6b222389c962 (patch)
treea8291669d3dd024faece0c3e4066fc4007061758 /gnu/packages
parent503c2039a280dd52a751a6852b4157fccd1b4195 (diff)
downloadguix-0c0d84603d63ae9eb04edf39582a6b222389c962.tar.gz
gnu: soapyhackrf: Update to 0.3.3-1.fa83fac.
* gnu/packages/radio.scm (soapyhackrf): Update to 0.3.3-1.fa83fac.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/radio.scm50
1 files changed, 27 insertions, 23 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index b3a6aceaff..300f761eed 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -313,29 +313,33 @@ SoapySDR library.")
     (license license:expat)))
 
 (define-public soapyhackrf
-  (package
-    (name "soapyhackrf")
-    (version "0.3.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/pothosware/SoapyHackRF")
-             (commit (string-append "soapy-hackrf-" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1awn89z462500gb3fjb7x61b1znkjri9n1d39bqfip1qk4s11pxc"))))
-    (build-system cmake-build-system)
-    (inputs
-     `(("hackrf" ,hackrf)
-       ("soapysdr" ,soapysdr)))
-    (arguments
-     `(#:tests? #f))  ; No test suite
-    (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
-    (synopsis "SoapySDR HackRF module")
-    (description
-     "This package provides HackRF devices support to the SoapySDR library.")
-    (license license:expat)))
+  ;; Use commit because some fixes are not in a release yet
+  ;; (last release was in 2018).
+  (let ((commit "fa83fac695fad9e198cc9a19a1e1a9c344fc191f")
+        (revision "1"))
+    (package
+      (name "soapyhackrf")
+      (version (git-version "0.3.3" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/pothosware/SoapyHackRF")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0sfb2gq4lp1fff921xm3bqqjv3srdsczjj8ps5jfhxhr6yx3a329"))))
+      (build-system cmake-build-system)
+      (inputs
+       `(("hackrf" ,hackrf)
+         ("soapysdr" ,soapysdr)))
+      (arguments
+       `(#:tests? #f))  ; No test suite
+      (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
+      (synopsis "SoapySDR HackRF module")
+      (description
+       "This package provides HackRF devices support to the SoapySDR library.")
+      (license license:expat))))
 
 (define-public soapyrtlsdr
   (package