summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-08 14:43:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-08 14:43:38 +0100
commit14ed9b049e5375296f438213c42663579362da0e (patch)
tree1ace707bef650d8c4f1ea7f3b86f540703cddb31 /gnu/packages
parentc8060055de425764f58bb9d0a7756964d7eea58d (diff)
downloadguix-14ed9b049e5375296f438213c42663579362da0e.tar.gz
gnu: python2-markupsafe: Downgrade to 1.1.1.
* gnu/packages/python-xyz.scm (python2-markupsafe): Downgrade to 1.1.1,
because that's the last version to support Python 2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4b01fd50ea..ebe0b572d2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3966,10 +3966,22 @@ e.g. filters, callbacks and errbacks can all be promises.")
     (description
      "Markupsafe provides an XML/HTML/XHTML markup safe string implementation
 for Python.")
-    (license license:bsd-3)))
+    (license license:bsd-3)
+    (properties `((python2-variant . ,(delay python2-markupsafe))))))
 
+;; Version 1.1.1 is the last to support Python 2.
 (define-public python2-markupsafe
-  (package-with-python2 python-markupsafe))
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-markupsafe)))
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "MarkupSafe" version))
+       (sha256
+        (base32
+         "0sqipg4fk7xbixqd8kq6rlkxj664d157bdwbh93farcphf92x1r9"))))))
 
 (define-public python-jinja2
   (package