summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-15 15:17:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-15 15:22:12 +0200
commit1990524e3ef50002749761314158aebe1a3ec269 (patch)
tree4fa91ff896de946a675cfd3ce26caefc86e9d4d7 /gnu/packages
parentde68d54ba6fb46cf480a9956b48c0760fe9c4ddf (diff)
downloadguix-1990524e3ef50002749761314158aebe1a3ec269.tar.gz
gnu: Add r-aricode.
* gnu/packages/cran.scm (r-aricode): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e450960fed..c86a42458c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6841,6 +6841,30 @@ Rscript front-end and facilitates turning an R script into an executable
 script.")
     (license license:gpl3+)))
 
+(define-public r-aricode
+  (package
+    (name "r-aricode")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "aricode" version))
+              (sha256
+               (base32
+                "0772l9gyrih48l1kymih0mb7szjqqnwcm4lzj0yzp4cs8l2mdf4f"))))
+    (properties `((upstream-name . "aricode")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-matrix r-rcpp))
+    (home-page "https://github.com/jchiquet/aricode")
+    (synopsis "Efficient computations of standard clustering comparison measures")
+    (description
+     "This package implements an efficient O(n) algorithm based on
+bucket-sorting for fast computation of standard clustering comparison
+measures.  Available measures include @dfn{adjusted Rand index} (ARI),
+@dfn{normalized information distance} (NID), @dfn{normalized mutual
+information} (NMI), @dfn{adjusted mutual information} (AMI), @dfn{normalized
+variation information} (NVI) and entropy.")
+    (license license:gpl3+)))
+
 (define-public r-debugme
   (package
     (name "r-debugme")