summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 18:57:25 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:31 +0200
commit3c313f185f28e7d8e21f67057c752f5f02f24f93 (patch)
treebce049e4bad5e71420d007934c14c7f46b28ef8e /gnu/packages
parent99af41fa40742664c97c9ff7e651376eccae867b (diff)
downloadguix-3c313f185f28e7d8e21f67057c752f5f02f24f93.tar.gz
gnu: Add rust-slog-2.4.
* gnu/packages/crates-io.scm (rust-slog-2.4): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5a9dde5325..fa2147fc98 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5929,6 +5929,32 @@ data type.")
     (properties '((hidden? . #t)))
     (license license:expat)))
 
+(define-public rust-slog-2.4
+  (package
+    (name "rust-slog")
+    (version "2.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "slog" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "13jh74jlckzh5cygkhs0k4r82wnmw8ha2km829xwslhr83n2w6hy"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-erased-serde" ,rust-erased-serde-0.3))))
+    (home-page "https://github.com/slog-rs/slog")
+    (synopsis "Structured, extensible, composable logging for Rust")
+    (description
+     "Structured, extensible, composable logging for Rust.")
+    (license (list license:mpl2.0
+                   license:expat
+                   license:asl2.0))))
+
 (define-public rust-smallvec-0.6
   (package
     (name "rust-smallvec")