summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2021-10-08 14:12:00 -0400
committerLudovic Courtès <ludo@gnu.org>2021-10-25 20:32:03 +0200
commit419a778e4679b63b456ec6fad5ca88f120ed9d60 (patch)
treeb68488c71dc2c9023e0ef899041f970fb538a7a9 /gnu/packages
parent2be79191e0358130548f31c68d684e89a6e4b978 (diff)
downloadguix-419a778e4679b63b456ec6fad5ca88f120ed9d60.tar.gz
gnu: xdg-desktop-portal: Update to 1.10.1.
* gnu/packages/freedesktop.scm (xdg-desktop-portal): Update to 1.10.1.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 25660b8f85..966de38d6e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2283,16 +2283,15 @@ fallback to generic Systray support if none of those are available.")
 (define-public xdg-desktop-portal
   (package
     (name "xdg-desktop-portal")
-    (version "1.8.1")
+    (version "1.10.1")
     (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/flatpak/xdg-desktop-portal")
-                     (commit version)))
-              (file-name (git-file-name name version))
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/flatpak/xdg-desktop-portal/releases/download/"
+                    version "/xdg-desktop-portal-" version ".tar.xz"))
               (sha256
                (base32
-                "0pq0kmvzk56my396vh97pzw4wizwmlmzvv2kr2xv047x3044mr5n"))))
+                "199lqr2plsy9qqnxx5a381ml8ygcbz4nkjla5pvljjcrwzlqsygd"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)