summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-11-20 16:38:56 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-20 17:08:55 +0100
commit4378eb9a15fd0f4167ff1f7d798d3a6dc945dc1e (patch)
treecc2f41c0b6c4761244444c7674a47406198b2198 /gnu/packages
parentc2242284ab6e087721a21ee5402d18d49024eb75 (diff)
downloadguix-4378eb9a15fd0f4167ff1f7d798d3a6dc945dc1e.tar.gz
gnu: ocaml-tyxml: Update to 4.5.0.
* gnu/packages/ocaml.scm (ocaml-tyxml): Update to 4.5.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 848f56b14c..49ee3ac460 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6668,7 +6668,7 @@ stream, and convert everything to UTF-8.")
 (define-public ocaml-tyxml
   (package
     (name "ocaml-tyxml")
-    (version "4.4.0")
+    (version "4.5.0")
     (source
      (origin
        (method git-fetch)
@@ -6678,17 +6678,16 @@ stream, and convert everything to UTF-8.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1hw4phyadcfgywgh5sj87i76gp56qwxzwlcpfdwjbf6ggag9clmd"))))
+         "0bh66wknc7sx2r63kscp0hg6h73dkv6qpkx0cdz2qp7p28pg2ixz"))))
     (build-system dune-build-system)
     (inputs
      `(("ocaml-re" ,ocaml-re)
        ("ocaml-seq" ,ocaml-seq)
-       ("ocaml-uutf" ,ocaml-uutf)
-       ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
-       ("ocaml-markup" ,ocaml-markup)))
+       ("ocaml-uutf" ,ocaml-uutf)))
     (native-inputs
      `(("ocaml-alcotest" ,ocaml-alcotest)))
     (arguments `(#:package "tyxml"))
+    (properties `((ocaml4.07-variant . ,(delay ocaml4.07-tyxml))))
     (home-page "https://github.com/ocsigen/tyxml/")
     (synopsis "TyXML is a library for building correct HTML and SVG documents")
     (description "TyXML provides a set of convenient combinators that uses the
@@ -6700,6 +6699,22 @@ also create your own representation and use it to instantiate a new set of
 combinators.")
     (license license:lgpl2.1)))
 
+(define-public ocaml4.07-tyxml
+  (package-with-ocaml4.07
+    (package
+      (inherit ocaml-tyxml)
+      (version "4.4.0")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/ocsigen/tyxml")
+                       (commit version)))
+                (file-name (git-file-name "ocaml-tyxml" version))
+                (sha256
+                 (base32
+                  "1hw4phyadcfgywgh5sj87i76gp56qwxzwlcpfdwjbf6ggag9clmd"))))
+      (properties '()))))
+
 (define-public ocaml-bisect-ppx
   (package
     (name "ocaml-bisect-ppx")