summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-09 16:54:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 14:37:03 +0100
commit91d4a78f41fd101148d76f91e6f45c9be8069564 (patch)
treec9f90d928fb02b1370ad12e8bb3a7ebb92fd4628 /gnu/packages
parenteb2337982888a1445d1b6067ff6090f08dd0b8ae (diff)
downloadguix-91d4a78f41fd101148d76f91e6f45c9be8069564.tar.gz
gnu: Add python-cleanlab-1.
* gnu/packages/machine-learning.scm (python-cleanlab-1): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/machine-learning.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 6546a17f5c..21a1ae0f61 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1329,6 +1329,31 @@ data-centric AI package facilitates machine learning with messy, real-world
 data by providing clean labels during training.")
     (license license:agpl3+)))
 
+(define-public python-cleanlab-1
+  (package
+    (inherit python-cleanlab)
+    (name "python-cleanlab")
+    (version "1.0.1")
+    ;; The version on pypi does not come with tests.
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/cleanlab/cleanlab")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "03kw2agnhadmrq9zvrlvvlc2c37dpflga5nhmsaag8scw223gqyp"))))
+    (build-system pyproject-build-system)
+    (arguments (list))
+    (propagated-inputs
+     (list python-numpy
+           python-scikit-learn
+           python-scipy
+           python-tqdm))
+    (native-inputs
+     (list python-pytest))))
+
 (define-public python-cmaes
   (package
     (name "python-cmaes")