summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-16 01:54:34 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:05:59 +0100
commit94fbcf7b78e136b7c53c10c3ecfce8a5a6768478 (patch)
tree729d6a1036f1e3cc18307919b373bc3cb3cba74c /gnu/packages
parentb737607c549765da0a89ae362d1294379884a0dd (diff)
downloadguix-94fbcf7b78e136b7c53c10c3ecfce8a5a6768478.tar.gz
gnu: Add rcs-blame.
* gnu/packages/version-control.scm (rcs-blame): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 739bb28355..10487c6939 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -41,6 +41,7 @@
 ;;; Copyright © 2021 François J. <francois-oss@avalenn.eu>
 ;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2068,6 +2069,27 @@ administration files, for example, which are often inherently local to one
 machine.")
     (license license:gpl3+)))
 
+(define-public rcs-blame
+  (package
+    (name "rcs-blame")
+    (version "1.3.1-20210207")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "https://invisible-mirror.net/archives/rcs-blame/blame-"
+                   version ".tgz"))
+             (sha256
+              (base32
+               "1j0brsvdx3hlbwchddafh8r2xmxv5vg4ahpd68v4bb9xhcq6pcih"))))
+    (build-system gnu-build-system)
+    (home-page "https://invisible-island.net/rcs-blame/rcs-blame.html")
+    (synopsis "Display the last modification for each line in an RCS file")
+    (description
+     "@code{blame} outputs an annotated revision from each RCS file.  An
+annotated RCS file describes the revision and date in which each line was
+added to the file, and the author of each line.")
+    (license license:gpl2+)))
+
 (define-public cvs
   (package
     (name "cvs")