summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-29 22:41:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-29 23:43:32 +0200
commitaa4885b3fb652b42762e587372d8154db2f47620 (patch)
treeb1a0d79b0a00cbde68a6d133b5e570bd6c6f1184 /gnu/packages
parente4ed0b3969ddbe44347c468c96ccfa057b2dd256 (diff)
downloadguix-aa4885b3fb652b42762e587372d8154db2f47620.tar.gz
gnu: python2-pytest-mock: Downgrade to 1.10.1.
* gnu/packages/check.scm (python2-pytest-mock)[propagated-inputs]: Only use
python2-mock and python2-pytest.
[version]: Downgrade to 1.10.1.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index f3e12ab16f..4701d61a9e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1372,11 +1372,21 @@ same arguments.")
 
 (define-public python2-pytest-mock
   (let ((base (package-with-python2
-                (strip-python2-variant python-pytest-mock))))
+               (strip-python2-variant python-pytest-mock))))
     (package/inherit base
+      (version "1.10.1")
+      (source
+       (origin
+         (method url-fetch)
+         (uri (pypi-uri "pytest-mock" version))
+         (sha256
+          (base32
+           "1i5mg3ff1qk0wqfcxfz60hwy3q5dskdp36i10ckigkzffg8hc3ad"))))
+      (arguments
+       `(#:python ,python-2))
       (propagated-inputs
        `(("python2-mock" ,python2-mock)
-         ,@(package-propagated-inputs base))))))
+         ("python2-pytest" ,python2-pytest))))))
 
 (define-public python-pytest-xdist
   (package