summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-22 07:34:57 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-04 21:07:07 -0400
commitb24c1f5fbdfeaf0a76803b976d3477abf6989e61 (patch)
treea4db4a580ec42a3ee886f3871ecd042f2b556f57 /gnu/packages
parentf08d3d7ad9e66155b562f5e24acf9ca32b15e3b9 (diff)
downloadguix-b24c1f5fbdfeaf0a76803b976d3477abf6989e61.tar.gz
gnu: Add perl-text-parsewords.
* gnu/packages/perl.scm (perl-text-parsewords): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5f443bcc1b..91f077c6a4 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -10251,6 +10251,24 @@ template engine, for when you need speed rather than complex features,
 yet need more features than simple variable substitution.")
     (license (package-license perl))))
 
+(define-public perl-text-parsewords
+  (package
+    (name "perl-text-parsewords")
+    (version "3.30")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CH/CHORNY/"
+                           "Text-ParseWords-" version ".tar.gz"))
+       (sha256
+        (base32 "1s7mmznk4chdvfi2jl2h6gawfaqq24bdasy6b1z9jhyxg60j7q45"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/dist/Text-ParseWords")
+    (synopsis "Parse text into an array of tokens or array of arrays")
+    (description "Text::ParseWords module is used to parse text into an array of
+tokens or array of arrays.")
+    (license (package-license perl))))
+
 (define-public perl-text-patch
   (package
     (name "perl-text-patch")