summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-30 18:11:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-03-30 19:41:35 +0300
commitcdba566261428d8949fcc4f7c7066a578e3009eb (patch)
treefbbd219fdca4bb807a03419b1e2e29164c439689 /gnu/packages
parent1bd8dadbe46e3ca0559ef46ae2c9a3a008a88027 (diff)
downloadguix-cdba566261428d8949fcc4f7c7066a578e3009eb.tar.gz
gnu: guile: Skip OOM test on powerpc64le-linux.
* gnu/packages/guile/scm (guile-3.0)[arguments]: Add phase when building
for powerpc64le-linux disabling the OOM test.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 8d25614e3a..972a391a29 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -391,6 +391,13 @@ without requiring the source code to be rewritten.")
                             (("^GUILE_OPTIMIZATIONS.*")
                              "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
                    #~())
+            #$@(if (target-ppc64le?)
+                   #~((add-after 'unpack 'skip-oom-test
+                        (lambda _
+                          ;; This test hangs with guile-3.0.9 and libgc-8.2.2.
+                          (substitute* "test-suite/standalone/test-out-of-memory"
+                            (("!#") "!#\n\n(exit 77)\n")))))
+                   #~())
             #$@(if (or (target-ppc32?)
                        (target-riscv64?))
                    #~((add-after 'unpack 'skip-failing-fdes-test