summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-23 17:29:50 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-01-25 22:21:28 -0500
commitcf31ee0427ad9ac254a7fc2af9a4599d44c22f97 (patch)
treed31005f80c003c343e10a54394c3b557869c1d98 /gnu/packages
parent1d41f7770182f4225dcb7ab197bf0a5b9cca603a (diff)
downloadguix-cf31ee0427ad9ac254a7fc2af9a4599d44c22f97.tar.gz
gnu: Add avogadro2.
* gnu/packages/chemistry.scm (avogadro2): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/chemistry.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index e2a1ef57e1..5351ea596b 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -179,6 +179,41 @@ processing useful in computational chemistry, molecular modeling,
 bioinformatics, materials science, and related areas.")
     (license license:bsd-3)))
 
+(define-public avogadro2
+  (package
+    (name "avogadro2")
+    (version "1.93.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/OpenChemistry/avogadroapp")
+             (commit version)))
+       (sha256
+        (base32
+         "1z3pjlwja778a1dmvx9aqz2hlw5q9g3kqxhm9slz08452600jsv7"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("eigen" ,eigen)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("avogadrolibs" ,avogadrolibs)
+       ("hdf5" ,hdf5)
+       ("molequeue" ,molequeue)
+       ("qtbase" ,qtbase)))
+    ;; TODO: Enable tests with "-DENABLE_TESTING" configure flag.
+    (arguments
+     '(#:tests? #f))
+    (home-page "https://www.openchemistry.org/projects/avogadro2/")
+    (synopsis "Advanced molecule editor")
+    (description
+     "Avogadro 2 is an advanced molecule editor and visualizer designed for use
+in computational chemistry, molecular modeling, bioinformatics, materials
+science, and related areas.  It offers flexible high quality rendering and a
+powerful plugin architecture.")
+    (license license:bsd-3)))
+
 (define-public domainfinder
   (package
     (name "domainfinder")