summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRobby Zambito <contact@robbyzambito.me>2021-10-19 22:19:36 -0400
committerLudovic Courtès <ludo@gnu.org>2021-10-28 21:30:27 +0200
commitd0850dbd345373fb7c78b2915e94a2f41983ea99 (patch)
treed198a61a279970b6605e6125ba7faa4bae992a63 /gnu/packages
parente171182a20962c4119e12439b92bbbfd59b1495e (diff)
downloadguix-d0850dbd345373fb7c78b2915e94a2f41983ea99.tar.gz
gnu: waypipe: Simplify 'fix-sleep-path phase.
* gnu/packages/freedesktop.scm (waypipe)
[arguments]: Remove inputs argument.
[native-inputs]: Remove coreutils.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/freedesktop.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e2a4a264e9..f824633ea2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2451,16 +2451,14 @@ compositors.")
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-sleep-path
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((coreutils (assoc-ref inputs "coreutils")))
-               (substitute* "./test/startup_failure.py"
-                 (("sleep") (string-append coreutils "/bin/sleep")))))))))
+           (lambda* (#:key #:allow-other-keys)
+             (substitute* "./test/startup_failure.py"
+               (("sleep") (which "sleep"))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("scdoc" ,scdoc)
        ;; For tests
-       ("python" ,python)
-       ("coreutils" ,coreutils)))
+       ("python" ,python)))
     (home-page "https://gitlab.freedesktop.org/mstoeckl/waypipe")
     (synopsis "Proxy for Wayland protocol applications")
     (description