summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2021-07-21 10:54:14 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-07-27 19:10:28 +0200
commitf62c140f47556dd1c80bc7b5de51209779088c4a (patch)
tree598d33b45c7fc32fc709d1e1ecabfb7781c647ef /gnu/packages
parent4c4cf3d6927cdfab54ab517a32fec6316f0f7eca (diff)
downloadguix-f62c140f47556dd1c80bc7b5de51209779088c4a.tar.gz
gnu: emacs-elpher: Update to 2.10.3.
* gnu/packages/emacs-xyz.scm (emacs-elpher): Update to 2.10.3.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm53
1 files changed, 28 insertions, 25 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 85f3fdf0e1..789cecf502 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25384,37 +25384,40 @@ it forcibly
       (license license:gpl3+))))
 
 (define-public emacs-elpher
-  (package
-    (name "emacs-elpher")
-    (version "2.10.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "git://thelambdalab.xyz/elpher.git")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0xqiisirpvw4ka9417pq4r73x937wl3qbf8cpn2i03akm8d58smd"))))
-    (build-system emacs-build-system)
-    (native-inputs
-     `(("texinfo" ,texinfo)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'build-doc
-           (lambda _
-             (invoke "makeinfo" "elpher.texi"))))))
-    (home-page "gopher://thelambdalab.xyz/1/projects/elpher/")
-    (synopsis "Gopher and gemini client for Emacs")
-    (description "Elpher is a full-featured gopher and gemini client for
+  ;; No tagged release upstream, but the commit below corresponds to the 2.10.3
+  ;; release.
+  (let ((commit "b0272de36cea3e1cd41cd15a012c8141b4b04575"))
+    (package
+      (name "emacs-elpher")
+      (version "2.10.3")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "git://thelambdalab.xyz/elpher.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1m6lq47i4j6k76f81vcch6akab9mqph7kna3fn356295fvgm7j7q"))))
+      (build-system emacs-build-system)
+      (native-inputs
+       `(("texinfo" ,texinfo)))
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (add-before 'install 'build-doc
+             (lambda _
+               (invoke "makeinfo" "elpher.texi"))))))
+      (home-page "gopher://thelambdalab.xyz/1/projects/elpher/")
+      (synopsis "Gopher and gemini client for Emacs")
+      (description "Elpher is a full-featured gopher and gemini client for
 Emacs.  Its features include intuitive keyboard and mouse-driven browsing,
 out-of-the-box compatibility with evil-mode, clickable links in plain text,
 caching of visited sites, pleasant and configurable visualization of Gopher
 directories, direct visualisation of image files, jumping directly to links by
 name (with autocompletion), a simple bookmark management system and
 connections using TLS encryption.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-zerodark-theme
   (package