summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-04-18 23:17:11 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-18 23:17:11 +0200
commitfc2d94a3f95b3a8f6e469fdd3cb92bdf110e1bd2 (patch)
tree4f847e5f8409fe7d53d8eef1534229cea6e510cd /gnu/packages
parent2aa5329023128168db2691ed26fb512f9dac0c48 (diff)
downloadguix-fc2d94a3f95b3a8f6e469fdd3cb92bdf110e1bd2.tar.gz
gnu: Add python-ajsonrpc.
* gnu/packages/python-web.scm (python-ajsonrpc): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d77e310835..7e333916b6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6444,3 +6444,25 @@ library for accessing the Twitter API.")
      "This package provides a Python ASGI web microframework with the same API
 as Flask.")
     (license license:expat)))
+
+(define-public python-ajsonrpc
+  (package
+    (name "python-ajsonrpc")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ajsonrpc" version))
+       (sha256
+        (base32 "17x1a4r4l428mhwn53abki9gzdzq3halyr4lj48fw3dzy0caq6vr"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-quart
+           python-sanic
+           python-tornado))
+    (home-page "https://github.com/pavlov99/ajsonrpc")
+    (synopsis "Async JSON-RPC 2.0 protocol and server")
+    (description
+     "This package provides a Python JSON-RPC 2.0 protocol and server powered
+by asyncio.")
+    (license license:expat)))