summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-04 11:25:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-04 11:25:48 +0200
commit32da38d5721663a470b335f86b67cffdc4f34f0a (patch)
treeb633522943117bf3552195ef77ae74470b706ce0 /gnu/packages
parent0c0431f9ce32a64ca663a2c5fc6656cbb86dc245 (diff)
parentc0e7a52996edf75a403ef6c454072271fd1c277a (diff)
downloadguix-32da38d5721663a470b335f86b67cffdc4f34f0a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/education.scm11
-rw-r--r--gnu/packages/irc.scm3
-rw-r--r--gnu/packages/password-utils.scm14
-rw-r--r--gnu/packages/patches/quassel-qt-5.11.patch72
-rw-r--r--gnu/packages/qt.scm16
-rw-r--r--gnu/packages/w3m.scm7
6 files changed, 112 insertions, 11 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 03050ffd0a..15b893c30d 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -115,7 +115,7 @@ of categories with some of the activities available in that category.
 (define-public gcompris-qt
   (package
     (name "gcompris-qt")
-    (version "0.90")
+    (version "0.91")
     (source
       (origin
         (method url-fetch)
@@ -124,11 +124,18 @@ of categories with some of the activities available in that category.
                version ".tar.xz"))
         (sha256
          (base32
-          "1i5adxnhig849qxwi3c4v7r84q6agx1zxkd69fh4y7lcmq2qiaza"))))
+          "09h098w9q79hnzla1pcpqlnnr6dbafm4q6zmdp7wlk11ym8n9kvg"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-for-qt5.11
+           (lambda _
+             (substitute* "src/core/CMakeLists.txt"
+               (("qt5_use_modules") "target_link_libraries")
+               (("Qml Quick Gui Multimedia Network XmlPatterns Svg Xml Sensors Core")
+                "Qt5::Qml Qt5::Quick Qt5::Gui Qt5::Multimedia Qt5::Core Qt5::Svg Qt5::Xml Qt5::XmlPatterns Qt5::Sensors"))
+             #t))
          (add-after 'install 'wrap-executable
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 2b266748ae..993102f272 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -74,6 +74,7 @@
         (sha256
          (base32
           "1qkl3sb4ijx4k17m0c42j2p5bc4jymypwhmplm942rbrzm6mg50q"))
+        (patches (search-patches "quassel-qt-5.11.patch"))
         (modules '((guix build utils)))
         ;; We don't want to install the bundled scripts.
         (snippet
@@ -92,7 +93,7 @@
                            "-DUSE_QT5=ON" ; default is qt4
                            "-DWITH_KDE=OFF" ; no to kde integration ...
                            "-DWITH_OXYGEN=ON" ; therefore we install bundled icons
-                           "-DWITH_WEBKIT=OFF") ; qtwebkit isn't packaged
+                           "-DWITH_WEBKIT=OFF") ; we don't depend on qtwebkit
        #:tests? #f)) ; no test target
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 011cf594d1..497963af63 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
-;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
@@ -110,7 +110,17 @@ human.")
     (arguments
      '(#:configure-flags '("-DWITH_XC_NETWORKING=YES"
                            "-DWITH_XC_BROWSER=YES"
-                           "-DWITH_XC_SSHAGENT=YES")))
+                           "-DWITH_XC_SSHAGENT=YES")
+       #:phases
+       (modify-phases %standard-phases
+         ;; should be fixed in 2.3.3+, see:
+         ;; https://github.com/keepassxreboot/keepassxc/pull/1964
+         (add-after 'unpack 'patch-sources
+           (lambda _
+             (substitute* "src/gui/entry/EditEntryWidget.cpp"
+               (("#include <QColorDialog>") "#include <QColorDialog>
+#include <QButtonGroup>"))
+             #t)))))
     (inputs
      `(("argon2" ,argon2)
        ("curl" ,curl) ; XC_NETWORKING
diff --git a/gnu/packages/patches/quassel-qt-5.11.patch b/gnu/packages/patches/quassel-qt-5.11.patch
new file mode 100644
index 0000000000..545f8b7610
--- /dev/null
+++ b/gnu/packages/patches/quassel-qt-5.11.patch
@@ -0,0 +1,72 @@
+https://github.com/quassel/quassel/commit/92f4dca367c3a6f0536a1e0f3fbb44bb6ed4da62.patch
+This can be removed after quassel 0.12.5.
+
+From 92f4dca367c3a6f0536a1e0f3fbb44bb6ed4da62 Mon Sep 17 00:00:00 2001
+From: Manuel Nickschas <sputnick@quassel-irc.org>
+Date: Thu, 3 May 2018 23:19:34 +0200
+Subject: [PATCH] cmake: Fix build with Qt 5.11
+
+Qt 5.11 removes the qt5_use_modules function, so add a copy. If
+present, the Qt-provided function will be used instead.
+
+Closes GH-355.
+---
+ cmake/QuasselMacros.cmake | 38 ++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 38 insertions(+)
+
+diff --git a/cmake/QuasselMacros.cmake b/cmake/QuasselMacros.cmake
+index 652c0042d..d77ba1cfb 100644
+--- a/cmake/QuasselMacros.cmake
++++ b/cmake/QuasselMacros.cmake
+@@ -5,6 +5,9 @@
+ # The qt4_use_modules function was taken from CMake's Qt4Macros.cmake:
+ # (C) 2005-2009 Kitware, Inc.
+ #
++# The qt5_use_modules function was taken from Qt 5.10.1 (and modified):
++# (C) 2005-2011 Kitware, Inc.
++#
+ # Redistribution and use is allowed according to the terms of the BSD license.
+ # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+ 
+@@ -43,6 +46,41 @@ function(qt4_use_modules _target _link_type)
+     endforeach()
+ endfunction()
+ 
++# Qt 5.11 removed the qt5_use_modules function, so we need to provide it until we can switch to a modern CMake version.
++# If present, the Qt-provided version will be used automatically instead.
++function(qt5_use_modules _target _link_type)
++    if (NOT TARGET ${_target})
++        message(FATAL_ERROR "The first argument to qt5_use_modules must be an existing target.")
++    endif()
++    if ("${_link_type}" STREQUAL "LINK_PUBLIC" OR "${_link_type}" STREQUAL "LINK_PRIVATE" )
++        set(_qt5_modules ${ARGN})
++        set(_qt5_link_type ${_link_type})
++    else()
++        set(_qt5_modules ${_link_type} ${ARGN})
++    endif()
++
++    if ("${_qt5_modules}" STREQUAL "")
++        message(FATAL_ERROR "qt5_use_modules requires at least one Qt module to use.")
++    endif()
++    foreach(_module ${_qt5_modules})
++        if (NOT Qt5${_module}_FOUND)
++            find_package(Qt5${_module} PATHS "${_Qt5_COMPONENT_PATH}" NO_DEFAULT_PATH)
++            if (NOT Qt5${_module}_FOUND)
++                message(FATAL_ERROR "Can not use \"${_module}\" module which has not yet been found.")
++            endif()
++        endif()
++        target_link_libraries(${_target} ${_qt5_link_type} ${Qt5${_module}_LIBRARIES})
++        set_property(TARGET ${_target} APPEND PROPERTY INCLUDE_DIRECTORIES ${Qt5${_module}_INCLUDE_DIRS})
++        set_property(TARGET ${_target} APPEND PROPERTY COMPILE_DEFINITIONS ${Qt5${_module}_COMPILE_DEFINITIONS})
++        if (Qt5_POSITION_INDEPENDENT_CODE
++                AND (CMAKE_VERSION VERSION_LESS 2.8.12
++                    AND (NOT CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
++                    OR CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0)))
++            set_property(TARGET ${_target} PROPERTY POSITION_INDEPENDENT_CODE ${Qt5_POSITION_INDEPENDENT_CODE})
++        endif()
++    endforeach()
++endfunction()
++
+ # Some wrappers for simplifying dual-Qt support
+ 
+ function(qt_use_modules)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 020cccd04d..7d323cd2d5 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1521,7 +1521,7 @@ message.")))
 (define-public python-sip
   (package
     (name "python-sip")
-    (version "4.19.3")
+    (version "4.19.8")
     (source
       (origin
         (method url-fetch)
@@ -1530,7 +1530,7 @@ message.")))
                          "sip-" version "/sip-" version ".tar.gz"))
         (sha256
          (base32
-          "0x2bghbprwl3az1ni3p87i0bq8r99694la93kg65vi0cz12gh3bl"))))
+          "1g4pq9vj753r2s061jc4y9ydzgb48ibhc9bdvmb8mlyllwp7mbvy"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("python" ,python-wrapper)))
@@ -1584,7 +1584,7 @@ module provides support functions to the automatically generated code.")
 (define-public python-pyqt
   (package
     (name "python-pyqt")
-    (version "5.9")
+    (version "5.10.1")
     (source
       (origin
         (method url-fetch)
@@ -1594,7 +1594,7 @@ module provides support functions to the automatically generated code.")
                          version ".tar.gz"))
         (sha256
          (base32
-          "15hh4z5vd45dcswjla58q6rrfr6ic7jfz2n7c8lwfb10rycpj3mb"))
+          "1vz9c4v0k8azk2b08swwybrshzw32x8djjpq13mf9v15x1qyjclr"))
        (patches (search-patches "pyqt-configure.patch"))))
     (build-system gnu-build-system)
     (native-inputs
@@ -1613,7 +1613,7 @@ module provides support functions to the automatically generated code.")
        ("qtsvg" ,qtsvg)
        ("qttools" ,qttools)
        ("qtwebchannel" ,qtwebchannel)
-       ("qtwebkit" ,qtwebkit)
+       ;("qtwebkit" ,qtwebkit)
        ("qtwebsockets" ,qtwebsockets)
        ("qtx11extras" ,qtx11extras)
        ("qtxmlpatterns" ,qtxmlpatterns)))
@@ -1622,6 +1622,12 @@ module provides support functions to the automatically generated code.")
                   ,@%gnu-build-system-modules)
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-build-with-qt-5.11
+           ;; See: https://bugs.gentoo.org/654742
+           (lambda _
+             (substitute* "sip/QtTest/qtestmouse.sip"
+               (("void waitForEvents\\(\\) /ReleaseGIL/;") ""))
+             #t))
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
diff --git a/gnu/packages/w3m.scm b/gnu/packages/w3m.scm
index db23b4d8df..4e3264a47e 100644
--- a/gnu/packages/w3m.scm
+++ b/gnu/packages/w3m.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,10 +25,12 @@
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages xorg)
   #:use-module (gnu packages)
   #:use-module (guix packages)
   #:use-module (guix git-download)
@@ -61,7 +64,9 @@
                        (("@PERL@") (which "perl")))
              #t)))))
     (inputs
-     `(("libgc" ,libgc)
+     `(("gdk-pixbuf" ,gdk-pixbuf)
+       ("libgc" ,libgc)
+       ("libx11" ,libx11)
        ("ncurses" ,ncurses)
        ("openssl" ,openssl)
        ("zlib" ,zlib)))