summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-27 13:20:47 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-27 14:08:55 -0500
commit0b1fae08d0b005380ff6c97c88abf5e6889f43f6 (patch)
treebf291e78fa03a21b0ed42d888279e307f45ac99e /gnu/packages
parenta8754d3160e1ef129e71f0e3a7edfa94c3649018 (diff)
downloadguix-0b1fae08d0b005380ff6c97c88abf5e6889f43f6.tar.gz
gnu: rw: Update to 0.9 and apply a patch to build with igraph >= 0.10.
* gnu/packages/patches/rw-igraph-0.10.patch: New file.
* gnu/local.mk: Register it.
* gnu/packages/graph.scm (rw): Update to 0.9.  Apply patch.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/graph.scm15
-rw-r--r--gnu/packages/patches/rw-igraph-0.10.patch17
2 files changed, 24 insertions, 8 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 5633dfdea6..d89c5d41e0 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -572,19 +572,18 @@ isolating planarity obstructions.")
     (name "rw")
     ;; There is a version 0.8, but the tarball is broken with symlinks
     ;; to /usr/share.
-    (version "0.7")
+    (version "0.9")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/rankwidth/"
                                   "rw-" version ".tar.gz"))
-       (sha256
-        (base32
-         "1rv2v42x2506x7f10349m1wpmmfxrv9l032bkminni2gbip9cjg0"))))
+              (sha256
+               (base32
+                "0hdlxxmlccb6fp7g58zv0rdzpbyjn9bgqlf052sgrk95zq33bq61"))
+              (patches (search-patches "rw-igraph-0.10.patch"))))
     (build-system gnu-build-system)
-    (native-inputs
-     (list pkg-config))
-    (inputs
-     (list igraph))
+    (native-inputs (list pkg-config))
+    (inputs (list igraph))
     (home-page "https://sourceforge.net/projects/rankwidth/")
     (synopsis "Rank-width and rank-decomposition of graphs")
     (description "rw computes rank-width and rank-decompositions
diff --git a/gnu/packages/patches/rw-igraph-0.10.patch b/gnu/packages/patches/rw-igraph-0.10.patch
new file mode 100644
index 0000000000..3544196660
--- /dev/null
+++ b/gnu/packages/patches/rw-igraph-0.10.patch
@@ -0,0 +1,17 @@
+Fix the build when using igraph >= 0.10.
+Retrieved from: https://sourceforge.net/p/rankwidth/tickets/2/.
+
+--- rw-0.9/simplerw.c.newigraph 2017-02-14 00:20:35.000000000 +0900
++++ rw-0.9/simplerw.c   2022-09-11 19:39:47.033917305 +0900
+@@ -134,7 +134,11 @@ int read_graph(const char *format, const
+ 		igraph_destroy(&igraph);
+ 		return(-1);
+ 	}
++#if (IGRAPH_VERSION_MAJOR >= 1) || ((IGRAPH_VERSION_MAJOR == 0) && (IGRAPH_VERSION_MINOR >= 10))
++	igraph_get_adjacency(&igraph, &imatrix, IGRAPH_GET_ADJACENCY_BOTH, NULL, IGRAPH_LOOPS_ONCE);
++#else
+ 	igraph_get_adjacency(&igraph, &imatrix, IGRAPH_GET_ADJACENCY_BOTH, 0);
++#endif
+ 	igraph_destroy(&igraph);
+ 	if(igraph_matrix_nrow(&imatrix) > MAX_VERTICES)
+ 	{