summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-27 16:57:36 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-27 17:42:51 +0200
commit040ae44aa1fb42b8e801b2abbebc8ec869eaaa65 (patch)
tree2e76b14643314b064fc0610467cb88104910cb9d /gnu/packages
parenta800c2175f47887eaba36cc8220f665026d433e5 (diff)
downloadguix-040ae44aa1fb42b8e801b2abbebc8ec869eaaa65.tar.gz
gnu: corkscrew: Download source from a mirror.
* gnu/packages/ssh.scm (corkscrew)[source]: Use
‘https://downloads.openwrt.org’.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 0443937749..67ffe1fac2 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -263,8 +263,11 @@ libssh library.")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://www.agroman.net/corkscrew/corkscrew-"
-                           version ".tar.gz"))
+       ;; The agroman.net domain name expired on 2017-03-23, and the original
+       ;; "http://www.agroman.net/corkscrew/corkscrew-2.0.tar.gz" now returns
+       ;; bogus HTML.  Perhaps it will yet return.  Until then, use a mirror.
+       (uri (string-append "https://downloads.openwrt.org/sources/"
+                           "corkscrew-" version ".tar.gz"))
        (sha256 (base32
                 "1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
     (build-system gnu-build-system)