summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorxd1le <elisp.vim@gmail.com>2015-10-10 22:06:40 +1100
committerAlex Kost <alezost@gmail.com>2015-10-16 19:54:42 +0300
commit1268e52d5de05f16396e2fa9e266f74b786131dc (patch)
treec628366297876928f722fcc7c1367b6633659edb /gnu/packages
parent998b8c07b8f06b44d962cd179b04bd93df9d56a7 (diff)
downloadguix-1268e52d5de05f16396e2fa9e266f74b786131dc.tar.gz
gnu: Add bspwm.
* gnu/packages/wm.scm (bspwm): New variable.

Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 9ca5b96fe8..e0859ccf30 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015 xd1le <elisp.vim@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -64,6 +65,39 @@ single/double-quoted strings, environment variable expansion, functions and
 nested include statements).")
     (license isc)))
 
+(define-public bspwm
+  (package
+    (name "bspwm")
+    (version "0.9")
+    (source
+     (origin
+       (file-name (string-append name "-" version ".tar.gz"))
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/baskerville/bspwm/archive/"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1pig0h2jk8wipyz90j69c4bk37bfyq60asnn0v0bqld2p2vjvyqy"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libxcb" ,libxcb)
+       ("libxinerama" ,libxinerama)
+       ("sxhkd" ,sxhkd)
+       ("xcb-util" ,xcb-util)
+       ("xcb-util-keysyms" ,xcb-util-keysyms)
+       ("xcb-util-wm" ,xcb-util-wm)))
+    (arguments
+     '(#:phases (alist-delete 'configure %standard-phases)
+       #:tests? #f  ; no check target
+       #:make-flags (list "CC=gcc"
+                          (string-append "PREFIX=" %output))))
+    (home-page "https://github.com/baskerville/bspwm")
+    (synopsis "Tiling window manager based on binary space partitioning")
+    (description "bspwm is a tiling window manager that represents windows as
+the leaves of a full binary tree.")
+    (license bsd-2)))
+
 (define-public i3status
   (package
     (name "i3status")