summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-09-15 19:30:21 +0200
committerMarius Bakke <marius@gnu.org>2021-09-15 23:38:51 +0200
commit16236cda58565b122e81e1f87a80a3e942ba6a3e (patch)
treeccf137738e51732f16aeca62f82e8df6a85adc39 /gnu/packages
parent16110ba476d90d0fb5b2921eb57f42f8faa3623c (diff)
downloadguix-16236cda58565b122e81e1f87a80a3e942ba6a3e.tar.gz
gnu: python-wtforms: Don't run style and coverage tests.
Such tests are fragile and does not affect functionality of the package.

* gnu/packages/python-web.scm (python-wtforms)[arguments]: In the check phase,
disable code coverage and pep8.
[native-inputs]: Remove PYTHON-COVERAGE and PYTHON-PEP8.
[source](uri): While at it, remove redundant '.tar.gz' argument to PYPI-URI.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ac9245ac7b..e1742cf71b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4155,7 +4155,7 @@ addon modules.")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "WTForms" version ".tar.gz"))
+       (uri (pypi-uri "WTForms" version))
        (sha256
         (base32
          "17427m7p9nn9byzva697dkykykwcp2br3bxvi8vciywlmkh5s6c1"))))
@@ -4174,11 +4174,9 @@ addon modules.")
              (when tests?
                (add-installed-pythonpath inputs outputs)
                (invoke "python" "setup.py" "compile_catalog")
-               (invoke "coverage" "run" "tests/runtests.py" "--with-pep8")))))))
+               (invoke "python" "tests/runtests.py")))))))
     (native-inputs
-     `(("python-coverage" ,python-coverage)
-       ("python-dateutil" ,python-dateutil)
-       ("python-pep8" ,python-pep8)
+     `(("python-dateutil" ,python-dateutil)
        ("python-sqlalchemy" ,python-sqlalchemy)))
     (propagated-inputs
      `(("python-babel" ,python-babel)