summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 14:52:16 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:35 +0200
commit18c2546078896a5e47f7b7a0a2a63a184b424bfe (patch)
tree69197e31cbedbf9bc858f7797de732747c97265c /gnu/packages
parent38a370d2bca0502d41186327a5478d542418739e (diff)
downloadguix-18c2546078896a5e47f7b7a0a2a63a184b424bfe.tar.gz
gnu: Add python2-stemming.
* gnu/packages/python.scm (python2-stemming): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4b87a3b3e1..c09242cb72 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14438,3 +14438,26 @@ system) by avoiding unnecessary calls to os.stat() in most cases.")
 
 (define-public python2-scandir
   (package-with-python2 python-scandir))
+
+(define-public python2-stemming
+  (package
+    (name "python2-stemming")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "stemming" version))
+       (sha256
+        (base32 "0ldwa24gnnxhniv0fhygkpc2mwgd93q10ag8rvzayv6hw418frsr"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2))
+    (home-page "https://bitbucket.org/mchaput/stemming/overview")
+    (synopsis "Python implementations of various stemming algorithms")
+    (description
+     "Python implementations of the Porter, Porter2, Paice-Husk, and Lovins
+stemming algorithms for English.  These implementations are straightforward and
+efficient, unlike some Python versions of the same algorithms available on the
+Web.  This package is an extraction of the stemming code included in the Whoosh
+search engine.")
+    (license license:public-domain)))