summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-09-03 15:45:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-13 19:13:43 +0200
commit1efcd0f1ea980472659805d91a2bb486b4136f81 (patch)
tree292304c106479324abf7a8a5c27138fcd729cf70 /gnu/packages
parentae72b8f55bba87eb87285eee9bdeaa95f213efd2 (diff)
downloadguix-1efcd0f1ea980472659805d91a2bb486b4136f81.tar.gz
gnu: Add r-abhgenotyper.
* gnu/packages/cran.scm (r-abhgenotyper): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7d65dfbdc1..a05834d7ea 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5736,3 +5736,29 @@ to obtain a practically sound, highly interpretable model.")
 Axon Instruments/Molecular Devices software.  Only files recorded in gap-free
 mode are currently supported.")
     (license license:artistic2.0)))
+
+(define-public r-abhgenotyper
+  (package
+    (name "r-abhgenotyper")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ABHgenotypeR" version))
+       (sha256
+        (base32 "08cpmnaaxsm5c5bjifnfxdlvg5inrf13biqpcl2yq5zpqjmiki0l"))))
+    (properties `((upstream-name . "ABHgenotypeR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-reshape2" ,r-reshape2)))
+    (home-page "https://github.com/StefanReuscher/ABHgenotypeR/")
+    (synopsis "Visualize and manipulate ABH genotypes")
+    (description
+     "The @code{r-abhgenotyper} package provides simple imputation,
+error-correction and plotting capacities for genotype data.  The package is
+supposed to serve as an intermediate but independent analysis tool between the
+TASSEL GBS pipeline and the @code{r-qtl} package.  It provides functionalities
+not found in either TASSEL or @code{r-qtl} in addition to visualization of
+genotypes as \"graphical genotypes\".")
+    (license license:gpl3)))