summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 00:03:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-19 02:45:14 +0100
commit24a87a14e13cf8edd1693da3e5dcc3d30d21486b (patch)
treee91cb4e3b9cd08f37950fdb7eb8f07c17306a3c6 /gnu/packages
parentf89cebb1e6d5b9cc0177e572b97f24cb91fd5e13 (diff)
downloadguix-24a87a14e13cf8edd1693da3e5dcc3d30d21486b.tar.gz
gnu: mpfi: Edit synopsis & description.
* gnu/packages/multiprecision.scm (mpfi)[synopsis, description]: Edit.
Define several terms.  Use GMP instead of MP for consistency.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/multiprecision.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index c7d47f5df8..291b81ae76 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -141,13 +141,16 @@ It supports arbitrarily high precision and it correctly rounds the results.")
     (build-system gnu-build-system)
     (propagated-inputs `(("gmp" ,gmp)   ; <mpfi.h> refers to both
                          ("mpfr" ,mpfr)))
-    (synopsis "C library for arbitrary precision interval arithmetic")
-    (description "MPFI is intended to be a portable library written in C for
-arbitrary precision interval arithmetic with intervals represented using MPFR
-reliable floating-point numbers.  It is based on the GNU MP library and on the
-MPFR library.  The purpose of an arbitrary precision interval arithmetic is on
-the one hand to get guaranteed results, thanks to interval computation, and on
-the other hand to obtain accurate results, thanks to multiple precision
-arithmetic.")
+    (synopsis "C library for arbitrary-precision interval arithmetic")
+    (description
+     "@dfn{MPFI} (Multiple Precision Floating-point Interval) is a portable C
+library for arbitrary-precision interval arithmetic, with intervals represented
+using MPFR reliable floating-point numbers.  It's based on the @dfn{GMP} (GNU
+Multiple Precision Arithmetic) and GNU@tie{}@dfn{MPFR} (Multiple Precision
+Floating-Point Reliably) libraries.
+
+The purpose of arbitrary-precision interval arithmetic is to get results that
+are both guaranteed, thanks to interval computation, and accurate, thanks to
+multiple-precision arithmetic.")
     (license lgpl2.1+)
     (home-page "https://perso.ens-lyon.fr/nathalie.revol/software.html")))