summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-10 19:37:57 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-12 21:40:55 +0100
commit2d8288040b83c31eb564630d7e3a8ba46e14599d (patch)
treecde8e2c7ca37d67dae39527434317c07e8a081e7 /gnu/packages
parent8c9653b3735749cc16e01c6d0a9de7a89e038a18 (diff)
downloadguix-2d8288040b83c31eb564630d7e3a8ba46e14599d.tar.gz
gnu: samba: Augment dynamic library rpaths.
* gnu/packages/samba.scm (samba): Augment the rpath of files in lib/ in
  addition to those in bin/ and sbin/.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/samba.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 46b97215ba..c147abcaab 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -114,11 +114,13 @@ anywhere.")
                   (lambda* (#:key outputs #:allow-other-keys)
                     (let* ((out (assoc-ref outputs "out"))
                            (lib (string-append out "/lib")))
-                      ;; Add LIB to the RUNPATH of all the executables.
+                      ;; Add LIB to the RUNPATH of all the executables and
+                      ;; dynamic libraries.
                       (with-directory-excursion out
                         (for-each (cut augment-rpath <> lib)
                                   (append (find-files "bin" ".*")
-                                          (find-files "sbin" ".*"))))))
+                                          (find-files "sbin" ".*")
+                                          (find-files "lib" ".*"))))))
                   %standard-phases))
 
        #:modules ((guix build gnu-build-system)