summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 23:13:25 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 23:13:25 -0500
commit337a94e534a9cdc5d70b92ef6adac7eed01a7a22 (patch)
treeea7f2062d0662a1d7c4e0fa6b1f303108730b445 /gnu/packages
parentbb557c9ac19ab01cdf621c3fac887750981feb77 (diff)
downloadguix-337a94e534a9cdc5d70b92ef6adac7eed01a7a22.tar.gz
gnu: python-pylint: Update to 2.6.0.
* gnu/packages/check.scm (python-pylint): Update to 2.6.0.
[arguments]: Partially reinstate the test suite.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/check.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0c1085cac9..11117b88e4 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -67,6 +67,7 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
@@ -2092,7 +2093,7 @@ statements in the module it tests.")
 (define-public python-pylint
   (package
     (name "python-pylint")
-    (version "2.5.3")
+    (version "2.6.0")
     (source
      (origin
        (method git-fetch)
@@ -2101,13 +2102,26 @@ statements in the module it tests.")
              (commit (string-append "pylint-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "04cgbh2z1mygar63plzziyz34yg6bdr4i0g63jp256fgnqwb1bi3"))))
+        (base32 "0ws3dz3wm49brnhhfm7v75zq202pwlwfbi3njdd69aqxq912x15z"))))
     (build-system python-build-system)
-    ;; FIXME: Tests are failing since version 2.4.3, see:
-    ;; https://github.com/PyCQA/pylint/issues/3198.
-    (arguments '(#:tests? #f))
+    (arguments
+     `(#:tests? #t
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; The following failing tests are skipped (see:
+               ;; https://github.com/PyCQA/pylint/issues/4068).
+               (invoke "pytest" "-k"
+                       (string-append
+                        "not unused_typing_imports "
+                        "and not star_needs_assignment_target_py35 "
+                        "and not regression_property_no_member_2641 "
+                        "and not missing_kwoa_py3"))))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)
+       ("python-pytest-benchmark" ,python-pytest-benchmark)
        ("python-pytest-runner" ,python-pytest-runner)
        ("python-tox" ,python-tox)))
     (propagated-inputs