summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-12-18 21:54:22 +0300
committerMathieu Othacehe <othacehe@gnu.org>2022-12-25 17:01:23 +0100
commit34feda1defbfbc23999489d3b9e1fa6bffbedd3b (patch)
treee81be88cf0ac61ce684e37342edd2eced582d3fb /gnu/packages
parent2967abf1a2ae6787842c04752949f3c214da9338 (diff)
downloadguix-34feda1defbfbc23999489d3b9e1fa6bffbedd3b.tar.gz
gnu: guile-png: Update to 0.3.0.
* gnu/packages/guile-xyz.scm (guile-png): Update to 0.3.0.
  [arguments]: Patch tests to silence Guile-SMC logs.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3fa75b26d1..50872b3f36 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3726,7 +3726,7 @@ debugging code.")
 (define-public guile-png
   (package
     (name "guile-png")
-    (version "0.2.0")
+    (version "0.3.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3735,10 +3735,21 @@ debugging code.")
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "1nk81z2cf9fsyppq5ly0yjw7yvdk5qraf71in7ayzdkngphhfgfx"))))
+                "1lv2cjzgrr0yshqng96l6bnn8pjmljv8qcn4w3wldh97ns7qigds"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+     `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+       #:phases
+       (modify-phases %standard-phases
+         ;; Guile-PNG tries to log parser messages to the syslog which is not
+         ;; available during the build.
+         (add-after 'unpack 'fix-tests
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (substitute* "tests/graphics.scm"
+               (("             \\(png graphics\\)\\)")
+                (string-append "             (png graphics)\n"
+                               "             (png fsm context))\n"
+                               "(log-clear-handlers!)"))))))))
     (native-inputs (list autoconf automake pkg-config texinfo))
     (inputs (list bash-minimal guile-3.0 guile-lib guile-zlib))
     (propagated-inputs (list guile-smc))