summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-02-03 19:50:00 +0100
committerKei Kebreau <kei@openmailbox.org>2017-02-03 14:12:51 -0500
commit37337699d7d6069ccd38aae6cc25bdbf4a6e56fc (patch)
tree77b04019b0552f212a94ddd56f6af4014d59cc2c /gnu/packages
parentf2de078a10fd18cab204cca81d398d3903b95341 (diff)
downloadguix-37337699d7d6069ccd38aae6cc25bdbf4a6e56fc.tar.gz
gnu: Add r-randomforest.
* gnu/packages/statistics.scm (r-randomforest): New variable.

Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 596c2baf5c..80f0b99b86 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2016 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2016 Raoul Bonnal <ilpuccio.febo@gmail.com>
+;;; Copyright © 2016, 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4145,3 +4145,25 @@ regression.")
 perform @dfn{independent component analysis} (ICA) and projection pursuit.")
     ;; Any GPL version.
     (license license:gpl3+)))
+
+(define-public r-randomforest
+  (package
+    (name "r-randomforest")
+    (version "4.6-12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "randomForest" version))
+       (sha256
+        (base32
+         "1i43idaihhl6nwqw42v9dqpl6f8z3ykcn2in32lh2755i27jylbf"))))
+    (properties `((upstream-name . "randomForest")))
+    (build-system r-build-system)
+    (home-page "https://www.stat.berkeley.edu/~breiman/RandomForests/")
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (synopsis "Breiman and Cutler's random forests for classification and regression")
+    (description
+"This package provides the Breiman and Cutler's random forests algorithm, based on a
+forest of trees using random inputs, for classification and regression.")
+    (license license:gpl2+)))