summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-02 10:05:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-02 10:24:25 +0100
commit3ee3e98971d37b176d5b167091aa6a13d4285c9e (patch)
tree060189938227efecb1831e4f2dae224dbb905ac7 /gnu/packages
parentc1377a323c0e77ed438c3f831aa726b3622e23b5 (diff)
downloadguix-3ee3e98971d37b176d5b167091aa6a13d4285c9e.tar.gz
gnu: Add python-bump2version.
* gnu/packages/python-xyz.scm (python-bump2version): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 068c2d2c1f..9ca1f624b0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3609,6 +3609,29 @@ text styles of documentation.")
                  (base32
                   "1zmhnswy0wxfn0xprs9aqsvx2c3kmzfn2wx14q8cv3vpkxdamj4q")))))))
 
+(define-public python-bump2version
+  (package
+    (name "python-bump2version")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "bump2version" version))
+       (sha256
+        (base32 "1rinm4gv1fyh7xjv3v6r1p3zh5kl4ry2qifz5f7frx31mnzv4b3n"))))
+    (build-system python-build-system)
+    (arguments
+     ;; XXX: Tests fail with "bumpversion: error: the following arguments are
+     ;; required: --new-version".
+     `(#:tests? #false))
+    (home-page "https://github.com/c4urself/bump2version")
+    (synopsis "Version-bump your software with a single command!")
+    (description
+     "This package provides a small command line tool to simplify releasing
+software by updating all version strings in your source code by the correct
+increment.  It also creates commits and tags.")
+    (license license:expat)))
+
 (define-public python-bumpversion
   (package
     (name "python-bumpversion")