summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-12-16 12:05:04 +0100
committerMathieu Othacehe <othacehe@gnu.org>2022-12-25 17:17:10 +0100
commit40cdf888925a2285a33f2e0bb39f2ccc1323a130 (patch)
treedcd4947486b2359d0e3637b9f28dd56c0b3986cb /gnu/packages
parent34feda1defbfbc23999489d3b9e1fa6bffbedd3b (diff)
downloadguix-40cdf888925a2285a33f2e0bb39f2ccc1323a130.tar.gz
gnu: vcsh: Update to 2.0.5.
* gnu/packages/version-control.scm (vcsh): Update to 2.0.5.
[native-inputs]: Remove which. Add autoconf, automake, ronn-ng, perl,
perl-test-harness, perl-shell-command, perl-test-most, pkg-config.
[inputs]: Remove perl, perl-test-harness, perl-shell-command,
perl-test-most.
[arguments]: Remove phase install-bash-completion. Add phase fix-version-gen.
Remove deletion of configure and build phases.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/version-control.scm33
1 files changed, 19 insertions, 14 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5da93fa0ce..5a5e4eb7a4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1408,7 +1408,7 @@ manipulate them in various ways.")
 (define-public vcsh
   (package
     (name "vcsh")
-    (version "1.20190621-4")
+    (version "2.0.5")
     (source
      (origin
        (method git-fetch)
@@ -1417,25 +1417,30 @@ manipulate them in various ways.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1gx5nbqyprgy6picns5hxky3lyzkqfq3xhm614f0wcdi58xrsdh0"))))
+        (base32 "15lb09c2q261p1pp5r7j9k8389ybrd2q19xhnp1nnha6gs78i4wq"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list which))
+     (list autoconf
+           automake
+           ;; for man page
+           ronn-ng
+           ;; for tests
+           perl
+           perl-test-harness
+           perl-shell-command
+           perl-test-most
+           ;; for bash-completion
+           pkg-config))
     (inputs
-     (list git perl perl-test-harness perl-shell-command perl-test-most))
+     (list git))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (delete 'configure)
-         (delete 'build)
-         (add-after 'install 'install-bash-completion
-           ;; As of 1.20190621, zsh completion is installed by default but bash
-           ;; completion is not.  Do so manually.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out         (assoc-ref outputs "out"))
-                    (completions (string-append out "/etc/bash_completion.d")))
-               (mkdir-p completions)
-               (copy-file "_vcsh_bash" (string-append completions "/vcsh"))))))
+         (add-before 'bootstrap 'fix-version-gen
+           (lambda _
+             (call-with-output-file ".tarball-version"
+               (lambda (port)
+                 (display version port))))))
        #:make-flags (list (string-append "PREFIX="
                                          (assoc-ref %outputs "out")))
        #:test-target "test"))