summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-25 05:16:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-25 05:17:42 +0200
commit413944234cf736f6e180a3c075df7e8229727d8f (patch)
tree367afc3f5faa91d15b0a213a86747de63cded59a /gnu/packages
parentaa4bde0b3a8e012124fabdfd0c74a76abd24597d (diff)
downloadguix-413944234cf736f6e180a3c075df7e8229727d8f.tar.gz
gnu: Add r-glmmtmb.
* gnu/packages/cran.scm (r-glmmtmb): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 70cba10132..4cd11bfd24 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6529,3 +6529,35 @@ most functions lies on summary statistics or fit measures for regression
 models, including generalized linear models, mixed effects models and Bayesian
 models.")
     (license license:gpl3)))
+
+(define-public r-glmmtmb
+  (package
+    (name "r-glmmtmb")
+    (version "0.2.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "glmmTMB" version))
+       (sha256
+        (base32
+         "1clpkjlmsjmn3m1z5jqv8cgw6bvpqsy4nx6k947r0jya017ny5y5"))))
+    (properties `((upstream-name . "glmmTMB")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-lme4" ,r-lme4)
+       ("r-matrix" ,r-matrix)
+       ("r-nlme" ,r-nlme)
+       ("r-rcppeigen" ,r-rcppeigen)
+       ("r-tmb" ,r-tmb)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/glmmTMB")
+    (synopsis "Generalized linear mixed models")
+    (description
+     "Fit linear and generalized linear mixed models with various extensions,
+including zero-inflation.  The models are fitted using maximum likelihood
+estimation via the Template Model Builder.  Random effects are assumed to be
+Gaussian on the scale of the linear predictor and are integrated out using the
+Laplace approximation.  Gradients are calculated using automatic
+differentiation.")
+    (license license:agpl3+)))