summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-02-13 11:17:57 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-02-14 17:04:42 +0200
commit4501a50bbdb35b4e0b5adf57c11a511af31f76f5 (patch)
tree3556ddf439b64d2fa068371ebadbf1e36d624bf2 /gnu/packages
parent25df704601b73fbdc083d57b68628960969f5cbe (diff)
downloadguix-4501a50bbdb35b4e0b5adf57c11a511af31f76f5.tar.gz
gnu: Add rust-protobuf-codegen-pure-2.
* gnu/packages/crates-io.scm (rust-protobuf-codegen-pure-2): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 44fe03206b..654e514fa8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -43199,6 +43199,30 @@ library to invoke programmatically (e.g. from @code{build.rs}) and
 @code{protoc-gen-rust} binary.")
     (license license:expat)))
 
+;; It's recommended that rust-protobuf, rust-protobuf-codegen
+;; and rust-probuf-codegen-pure be the same version
+(define-public rust-protobuf-codegen-pure-2
+  (package
+    (name "rust-protobuf-codegen-pure")
+    (version "2.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "protobuf-codegen-pure" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0h34gfqlb7bqmgqv1mfgy5wk35z5r2h5ki3p3pdcmw1vqzmly6id"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-protobuf" ,rust-protobuf-2)
+        ("rust-protobuf-codegen" ,rust-protobuf-codegen-2))))
+    (home-page "https://github.com/stepancheg/rust-protobuf/")
+    (synopsis "Pure-rust codegen for protobuf using protobuf-parser")
+    (description "This package provides a pure-rust codegen for protobuf
+using protobuf-parser.")
+    (license license:expat)))
+
 (define-public rust-psl-2
   (package
     (name "rust-psl")